Experiencing some slowness

Incident Report for Teamtailor

Resolved

This incident has been resolved.
Posted Dec 21, 2021 - 09:19 CET

Investigating

We are currently investigating this issue.
Posted Dec 21, 2021 - 09:10 CET
This incident affected: Applicant Tracking System (EU (Ireland)).