Delays in delivering emails
Incident Report for Teamtailor
Resolved
Our provider resolved the issue on their end and our systems have caught up with the backlog.

Sorry for the inconvenience.
Posted May 14, 2024 - 21:04 CEST
Monitoring
Our provider has fixed their issue, and emails are being delivered with slight delays.
Posted May 14, 2024 - 17:13 CEST
Identified
Our service provider is experiencing some slowness delivering and receiving emails: http://status.flowmailer.net/. We are monitoring the situation to ensure no emails are lost and will be delivered.
Posted May 14, 2024 - 15:08 CEST
Investigating
We are currently seeing a increased processing time for email handling, we are investigating.
Posted May 14, 2024 - 14:54 CEST
This incident affected: Applicant Tracking System (EU (Ireland)).