Issues delivering and receiving emails
Incident Report for Teamtailor
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 08:43 CET
Monitoring
Our provider has fixed their issue, and emails are being sent and received with normal timings.
Posted Dec 20, 2023 - 19:30 CET
Investigating
Our service provider is experiencing some slowness delivering and receiving emails: http://status.flowmailer.net/. We are monitoring the situation to ensure no emails are lost and will be delivered.
Posted Dec 20, 2023 - 14:56 CET
This incident affected: Applicant Tracking System (EU (Ireland)).