Issues accessing Teamtailor
Incident Report for Teamtailor
Resolved
This incident has been resolved, we're sorry for this inconvenience.
Posted Oct 13, 2021 - 15:12 CEST
Identified
We are working on solving this issue and hope to be back as soon as possible.
Posted Oct 13, 2021 - 15:10 CEST
Update
We are continuing to investigate this issue. We are very sorry for the inconvenience.
Posted Oct 13, 2021 - 14:54 CEST
Investigating
We are currently investigating this issue.
Posted Oct 13, 2021 - 14:41 CEST
This incident affected: Career site and job application and Applicant Tracking System.