A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2024 - 12:50 CEST
Identified
We are currently experiencing a delay in the delivery of notifications since yesterday. A correction for this is underway and should correct the issue later today.
Posted Aug 07, 2024 - 12:05 CEST
This incident affected: Applicant Tracking System (EU (Ireland), US West (Oregon)).