Issues loading calendar and some pages in Settings
Incident Report for Teamtailor
Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 15:57 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 28, 2021 - 14:31 CEST
Investigating
We are currently investigating this issue.
Posted Oct 28, 2021 - 14:15 CEST
This incident affected: Applicant Tracking System.