Intermittent error
Incident Report for Teamtailor
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 17:16 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2021 - 16:02 CEST
This incident affected: Career site and job application and Applicant Tracking System.