Delays in delivering emails
Incident Report for Teamtailor
Resolved
Our provider resolved the issue on their end and our systems have caught up with the backlog. Apologies for the inconvenience.
Posted Jun 26, 2024 - 16:36 CEST
Monitoring
Our provider has fixed their issue, and emails are being delivered with slight delays.
Posted Jun 26, 2024 - 15:35 CEST
Investigating
Our service provider is experiencing some slowness delivering and receiving emails: http://status.flowmailer.net/. We are monitoring the situation to ensure no emails are lost and will be delivered.
Posted Jun 26, 2024 - 15:09 CEST
This incident affected: Applicant Tracking System (EU (Ireland)).