Availability issue

Incident Report for Teamtailor

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 13:10 CEST

Monitoring

Response times are back to normal. We are monitoring the situation.
Posted Apr 16, 2025 - 12:41 CEST

Update

We are continuing to investigate this issue.
Posted Apr 16, 2025 - 12:36 CEST

Investigating

We are currently experiencing issues with slow response times on our EU-region. We are investigation the issue.
Posted Apr 16, 2025 - 12:35 CEST
This incident affected: API (EU (Ireland)), Career site and job application (EU (Ireland)), Applicant Tracking System (EU (Ireland)), and Analytics (EU (Ireland)).