Intermittent availability issue

Incident Report for Teamtailor

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 22:30 CET

Update

The issue has been identified and a fix is being implemented.
Posted Mar 04, 2025 - 22:00 CET

Investigating

We are currently experiencing intermittent availability issues affecting Career Sites and the ATS backend in our EU region. Our team is actively investigating and implementing mitigations.
Posted Mar 04, 2025 - 21:04 CET
This incident affected: API (EU (Ireland)), Career site and job application (EU (Ireland)), Applicant Tracking System (EU (Ireland)), and Analytics (EU (Ireland)).